
 

 

Using Signal Studio Waveform Licenses 

Software and Instrument Procedure 

 

 

 

This document describes how to: 

 Use the Signal Studio software to configure, generate, and download waveform files to your instrument 

 Play back waveforms for evaluation and permanently license  the ones you want to keep 

Before using this document, you must install an Agilent 5- or 50-pack waveform license in your instrument. For license 

installation instructions, go to http://wireless.agilent.com/wireless/helpfiles/license. 

The following instruments support waveform licensing: 

 N5162A MXG-ATE vector signal generator 

 N5182A MXG vector signal generator 

 E4438C ESG vector signal generator 

 E6607 EXT wireless communications test set 

Contents: 

Using Signal Studio to Create and Download a Waveform 

Method 1: live connection via LAN (MXG, ESG, EXT) 

Method 2: export waveform files to a USB storage device (MXG, EXT) 

Evaluating  and Locking Waveforms to License Slots 

On the MXG 

On the ESG 

On the EXT 
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Using Signal Studio to Create and Download a Waveform 

Method 1: live connection via LAN (MXG, ESG, EXT) 

Note: Some Signal Studio products do not support a live connection to the EXT. In these cases, use Method 2. 

1. From the Agilent website, www.agilent.com/find/signalstudio, download and install the N76xxB Signal 

Studio software of your choice. 

2. Open the software. The system configuration wizard appears. 

3. Select New hardware configuration and click OK. If your software was previously connected to the 

instrument, choose Most recently used hardware configuration. 

 

4. Select your instrument and click Next 

 

http://www.agilent.com/find/signalstudio
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5. Click Next. 

 

6. Enter your instrument's IP address and click Next. 
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7. Click Next. 

 

8. Enter a name for your instrument and click Finish. 
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9. From the software's tree view, select Licenses. Notice that the state of each license is set to Off and 

displays Invalid. If you are using the software's 14-day free trial or have previously purchased a basic 

capability option, those licenses will be valid and already set to On. 

 

10. Click the State field for each Off license and set to On. These licenses will continue to display Invalid. 
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11. Configure the Signal Studio waveform using the various parameter selections and settings available under 

the Waveform Setup node in the tree view. This example shows the carrier settings for the N7600B Signal 

Studio software. Waveform parameters vary among Signal Studio products, so refer to your software's 

help system for more information. 

 

12. From the tree view, select Waveform Setup and enter a Waveform Name. 

NOTE: Some Signal Studio applications do not allow waveform file names greater than eight characters. 
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13. Click the Generate and Download button. 

 

14. The following message appears. Click OK. 

 

The waveform file now resides in the volatile memory of your instrument. 

  



Using Signal Studio Waveform Licenses 

8 

Method 2: export waveform files to a USB storage device (MXG, EXT) 

1. From the Agilent website, www.agilent.com/find/signalstudio, download and install the N76xxB Signal 

Studio software of your choice. 

2. Open the software. The system configuration wizard appears. 

3. Select Simulated hardware and make sure RF Output (for Signal Generator) is highlighted. Click OK. 

 

4. Configure the Signal Studio waveform using the various parameter selections and settings available under 

the Waveform Setup node in the tree view. This example shows the carrier settings for the N7600B Signal 

Studio software. Waveform parameters vary among Signal Studio products, so refer to your software's 

help system for more information. 

 

http://www.agilent.com/find/signalstudio
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5. Click the Generate Waveform button. 

 

6. Under the File menu, select Export Waveform Data. 

 

7. Name the waveform file and save it to your PC. 

 

8. Copy the waveform file to a portable USB storage device. 
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9. Insert the USB storage device into the instrument's front panel USB port. Proceed to the appropriate step 

for your instrument model. 

10. For the EXT. Make sure the EXT user interface is the active window and press File > File Explorer. Then 

locate the USB storage device and copy your waveform file to D:\NVARB. You can navigate to this folder 

by selecting My Computer > User Data > NVARB. 

11. For the MXG. The USB file directory appears. Use the front panel knob to highlight your waveform file. 

Press Copy File to Instrument > Waveform > BBG Memory (volatile memory). 
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Evaluating and Locking Waveforms to License Slots 

On the MXG 

NOTE: If you are using an MXG-ATE, You must use the signal generator's web interface to perform the following steps. 

(For more information on using the web interface, refer to the MXG Installation Guide.) 

1. Press Local (same key as Cancel/(ESC)) to unlock the instrument from remote operation. 

2. Press Mode > Dual ARB > More > Waveform Licensing. The following screen appears, showing occupied 

and available waveform slots for your instrument's 5- or 50-pack license. 

 

3. Press Add Waveform To First Available Slot. You can also use the arrow keys or front panel knob to select 

an occupied waveform slot and then press Replace Waveform In Slot. This allows you to use the 

remaining trial time for that slot on your waveform. 

 

In either case, a screen appears, showing the available files stored in volatile BBG memory. The waveform 

file you created and downloaded with the Signal Studio software should now reside here.  
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4. Use the arrow keys or front panel knob to find your waveform file and press Add Waveform. Notice that 

you have 48 hours remaining to fully evaluate the waveform. The trial time applies to individual slots. 

Once a waveform is added to a slot, the trial time for that slot begins counting down and cannot be reset. 

During the trial time, you can replace and evaluate waveforms in a slot as many times as you like. At the 

end of the trial time, however, you can no longer play the waveform in that slot unless you license (lock) it 

to that slot. You can, however, still replace files in an expired, unlocked slot. 

 

5. To playback the waveform for evaluation, press Mode > Dual ARB > Select Waveform and use the arrow 

keys or front panel knob to find your waveform.  

NOTE: The instrument's user interface uses the term segment to refer to a waveform file. 

 

6. Press Select Waveform > ARB Off On to On. Set your frequency and amplitude for the carrier as you like 

and then press RF On/Off to On. You can now evaluate the waveform in your specific test scenario. 
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7. Prior to licensing (locking) your waveform file, you must save it to the instrument's non-volatile internal 

storage. Press Mode > Dual ARB > Select Waveform > Waveform Segments > Load Store to Store and use 

the arrow keys or front panel knob to select your waveform. Then press Store Segment to Int Media. If 

you do not save your waveform file to internal storage, you will be prompted to do so when you attempt 

to license the waveform file. 

 

8. To license the waveform into a 5- or 50-pack slot, press Mode > Dual ARB > More > Waveform Licensing 

and use the arrow keys or front panel knob to select your waveform file's slot. 
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9. Press Lock Waveform In Slot. A warning message appears. Press Confirm Locking Waveform. 

NOTE: Be sure to keep a backup copy of the waveform. 

 

10. Your waveform file is now locked to a 5- or 50-pack slot and permanently licensed to your instrument. 
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On the ESG 

1. Press Local to unlock the instrument from remote operation. 

2. Press Mode > Dual ARB > Waveform Licensing. The following screen appears, showing occupied and 

available waveform slots for your instrument's 5- or 50-pack license. 

 

3. Use the arrow keys or front panel know to highlight the first available slot. and press Add Waveform To 

First Available Slot. You can also select an occupied waveform slot and then press Replace Waveform In 

Slot. This allows you to use the remaining trial time for that slot on your waveform. 

 

In either case, a screen appears, showing the available files stored in volatile waveform memory (WFM1). 

The waveform file you created and downloaded with the Signal Studio software should now reside here.  
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4. Use the arrow keys or front panel knob to find your waveform file and press Add Waveform. Notice that 

you have 48 hours remaining to fully evaluate the waveform. The trial time applies to individual slots. 

Once a waveform is added to a slot, the trial time for that slot begins counting down and cannot be reset. 

During the trial time, you can replace and evaluate waveforms in a slot as many times as you like. At the 

end of the trial time, however, you can no longer play the waveform in that slot unless you license (lock) it 

to that slot. You can, however, still replace files in an expired, unlocked slot. 

 

5. To playback the waveform for evaluation, press Mode > Dual ARB > Select Waveform and use the arrow 

keys or front panel knob to find your waveform file. 

NOTE: The instrument's user interface uses the term segment to refer to a waveform file. 

 

6. Press Select Waveform > ARB Off On to On. Set your frequency and amplitude for the carrier as you like 

and then press RF On/Off to On. You can now evaluate the waveform in your specific test scenario. 
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7. Prior to licensing (locking) your waveform file, you must save it to the instrument's non-volatile waveform 

memory (NVWFM). Press Mode > Dual ARB > Select Waveform > Waveform Segments > Load Store to 

Store and use the arrow keys or front panel knob to select your waveform. Then press Store Segment to 

NVWFM. If you do not save your waveform file to internal storage, you will be prompted to do so when 

you attempt to license the waveform file. 

 

8. To license the waveform into a 5- or 50-pack slot, press Mode > Dual ARB > Waveform Licensing and use 

the arrow keys or front panel knob to select your waveform file's slot. 
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9. Press Lock Waveform In Slot. A warning message appears. Press Confirm Locking Waveform. 

NOTE: Be sure to keep a backup copy of the waveform. 

 

10. Your waveform file is now locked to a 5- or 50-pack slot and permanently licensed to your instrument. 
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On the EXT 

1. Press Local (same key as Cancel/(ESC)) to unlock the instrument from remote operation. 

2. Press Source > More 1 of 2 > Modulation Setup > ARB > More 1 of 2 > Waveform Utilities > Multi-Pack 

Licenses. The following screen appears, showing occupied and available waveform slots for your 

instrument's 5- or 50-pack license. 

 

3. Press Add Waveform > Segments on Hard Disk. Then use the arrow keys or mouse to select a waveform 

file from NVARB memory.  

NOTE: The instrument's user interface uses the term segment to refer to a waveform file. 
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4. Press Load Segment to ARB Memory. 

 

 
5. Press Return and use the arrow keys or mouse to select your waveform. Then press Add Waveform. A 

dialog box appears. Click OK.  
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6. Notice that you have less than 48 hours (display shows 47 hours) remaining to fully evaluate the 

waveform. The trial time applies to individual slots. Once a waveform is added to a slot, the trial time for 

that slot begins counting down and cannot be reset. During the trial time, you can replace and evaluate 

waveforms in a slot as many times as you like. At the end of the trial time, however, you can no longer 

play the waveform in that slot unless you license (lock) it to that slot. You can, however, still replace files 

in an expired, unlocked slot.  

 

7. To playback the waveform for evaluation, press Source > More 1 of 2 > Modulation Setup > ARB > Select 

Waveform and use the arrow keys or mouse to highlight your waveform. 

8. Press Select Waveform > Return > ARB Off On to On. Set your frequency and amplitude for the carrier as 

you like and then press Source > RF On/Off to On. You can now evaluate the waveform in your specific 

test scenario. 

9. To license the waveform into a 5- or 50-pack slot, press Source > More 1 of 2 > Modulation Setup > ARB > 

More 1 of 2 > Waveform Utilities > Multi-Pack Licenses and use the arrow keys or mouse to select your 

waveform file's slot. 
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10. Press Lock Waveform In Slot. A dialog box appears, asking you to confirm your decision. Click OK. 

NOTE: Be sure to keep a backup copy of the waveform. 

 

11. Your waveform file is now locked to a 5- or 50-pack slot and permanently licensed to your instrument. 
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